Industrial FAQ
  • Whaleflo Industrial  Pump FAQ
    Whaleflo Industrial Pump FAQ Oct 13, 2019
    Diaphragm Pump Trouble Shooting Problem Cause Solution Motordoesn’t start Electrical connections Blown fuse,main switch, and ground connection Motor hot Thermal Protect, Wait until motor cooling Incorrect Voltage Use correct voltages (+/-10%) Pump can not shut off Restricted inlet check the strainer, hose, valves loose drive assembly tighten the screw Air in the system check all fixtures Incorrect Voltage Use correct voltages (+_10%) By-pass set higher than shut-off Lower it down Noisy Restricted inlet check the strainer, hose, valves Air in the system check all fixtures Crude Mounting surface install on flat surface loose drive assembly tighten the screw ,and the mounting feet Leaks loose drive assembly tighten the screw switch or pump assembly rupture check the switch and pump head assembly, and replace the kits Low pressure/flow Air in the system check all fixtures leak check all fixtures Incorrect Voltage Use correct voltages (+_10%) Doesn’t Draw Water Problems on the suction line 1.Checksuction line,pipes or fittings are sucking in air.Inspected the entire suction line, ensured that pipes and fittings are securely fastened. Clogged suction filter 2.Clogged suction filter, if the suction line is intact and functioning, you must remove the suction filter and clean it if it is clogged.
    Read More
[  A total of  1  pages]
Leave a message

Leave a message

    If you are interested in our products and want to know more details,please leave a message here,we will reply you as soon as we can.

Home

Products

News

Contact

top